Virtuoso Service Center and Air Department Service Provider Telephone Issues
Incident Report for Virtuoso
Resolved
This incident has been resolved.
Posted Mar 13, 2019 - 18:31 PDT
Update
Dear Virtuosos,

The intermittent phone service issues affecting the Air Department and Service Center are now resolved. Phone lines are operational and calls are being routed as expected.

Please call or email the Service Center if you have any questions or need assistance. Thanks so much for your patience!

Best regards,

Virtuoso
817-870-0300
help@virtuoso.com
Posted Mar 13, 2019 - 18:29 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 13, 2019 - 12:20 PDT
Identified
Virtuoso's Telecom provider that routes inbound calls to our main Service Center and Air Department is currently experiencing technical issues. When calling into 817-870-0300, 817-334-8650 or other Virtuoso number, users may experience silence. Engineers on the telecom provider's side have identified the issue and are working on a resolution. At this time, please send your requests to Help@virtuoso.com while we continue to work with the service provider on the resolution. We will update this message as more information becomes available.

Best Regards,
Virtuoso Operations
Help@virtuoso.com
Posted Mar 13, 2019 - 12:18 PDT
This incident affected: Virtuoso Air Phone System and Virtuoso Service Center Phone System.