SERVICE ALERT: Virtuoso sites currently experiencing technical issues
Incident Report for Virtuoso
Resolved
This incident has been resolved.
Posted Mar 27, 2019 - 05:27 PDT
Update
We have found and resolved a timeout issue.
Posted Mar 27, 2019 - 05:25 PDT
Update
We are continuing to investigate this issue.
Posted Mar 27, 2019 - 05:15 PDT
Investigating
We are currently investigating this issue.
Posted Mar 27, 2019 - 05:15 PDT
This incident affected: Virtuoso Events (User Login) and www.virtuoso.com (User Login, Advisor Search, Cruise Search, Tour Search, Hotel Booking, Virtuoso Reports).